Transitioning to LabVIEW NXG

Ease the migration of your development skills and existing applications to LabVIEW NXG. For experienced LabVIEW users who want to begin using LabVIEW NXG for code development, this course guides you through the transition experience from LabVIEW 2017 and earlier to LabVIEW NXG.

Login to see if you have access to this course.

Share


OVERVIEW

Audience
  • Experienced LabVIEW users who want to begin using LabVIEW NXG for code development.
  • LabVIEW NXG users who want to know how to convert LabVIEW code for use in LabVIEW NXG.
Task-based Objectives After completing this course, you will be able to:
  • Describe the fundamental differences between the LabVIEW and LabVIEW NXG development environments.
  • Develop and deploy a state machine application from scratch using LabVIEW NXG.
  • Use the Code Conversion Utility and LabVIEW NXG development techniques to migrate a qualified application for use in LabVIEW NXG.
Learning Modules
  1. Exploring the LabVIEW NXG Environment
  2. Configuring Hardware
  3. Developing VIs
  4. Developing Object-Oriented Applications
  5. Debugging and Troubleshooting
  6. Distributing Code
  7. Putting it All Together Create a State Machine
  8. Migrating Simple VIs
  9. Migrating Reuse Libraries
  10. Calling Existing VIs from LabVIEW NXG
  11. Migrating an Application
  12. Continue Your LabVIEW Education

  View the detailed course outline.

RELATED NI LEARNING BADGES

   

RELATED PROFESSIONAL CERTIFICATIONS

  Currently there are no related professional certifications

RELATED LEARNING COURSES

PREPARE

  Gain recommended skills with these courses

NEXT STEPS

  Continue learning with these courses

CONSIDER

  Explore related topics with these courses
LabVEW NXG Core 1: Acquire, Analyze, Visualize    

Prefer a Live Instructor?

LabVIEW NXG

LabVIEW NXG gives you the ability to configure, automate, and visualize your test results, all within a single tool.

Prerequisites

 

  • LabVIEW Core 1 or equivalent experience
  • LabVIEW Core 2 or equivalent experience
  • Note: Users at all levels may benefit from the contents of this course, but some concepts may be unfamiliar.

 

System Requirements

 

NI Online Training courses are best utilized on systems meeting minimum requirements for best performance. Use the following guidelines:

 

Browser
  • Google Chrome (last two major versions)
  • Mozilla Firefox (latest two major versions) – Extended Support Release (ESR) versions not supported
  • Safari (current version) – Macintosh Only
  • Microsoft Edge (current patch level) – Windows Only

 

Operating System
  • Windows 7/8/10 or later
  • MAC OS X 10.10 or later

 

NI Hardware and Software Used or Referenced

 

Software
  • LabVIEW 2017 or later
  • LabVIEW NXG 2.0 or later
  • NI-DAQmx 17.5 or later
  • NI VISA 17.5 or later
  • NI Package Manager

 

Hardware
  • No Hardware Used

 

Log in to submit a comment.